Requirements

VPL Module

The VPL module requires a Moodle version 1.9.x and PHP5 or higher. To run or evaluate a submission is required to have at least one jail server. To provide execution in console the Moodle servers need to open at least two ports, a larger number is recommended. It takes more time than usual to execute the PHP scripts that run a submission so it is necessary increase time limit in the PHP configuration.

Jail Service

The jail service needs Ubuntu (recomended) or Red Hat compatible linux distribution. The jail software compilation requires a C++ compiler. The machine where the service

Browsers

To use full features you need a browser with the following characteristics:

  • JavaScript
  • Support for Java 1.5 applets

The system has been tested in recent versions of Firefox, MS Internet Explorer, Chrome and Opera, working properly.